$re = '/^(?:.(?=.*\n(\1?+.)))*?(?=Size)(?:\w\B(?=.*\n\1?+(\2?+\D)))*+.*\n\1?+\2?+(?<![\d.])\K[\d.]+/m';
$str = 'Property Size
Jerusale811.00
Property Size
Jerusalem811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
Property Size
Jerusalem 811.00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);