# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\G(\d+),(?=\d+(?:,\d+)*(?:\.\d+)?$)/$1/gm;t' <<< "11,340,567.65"