$re = '/^(?:\w+=\w*|=\w+)(?:&(?:\w+=\w*|=\w+))*$/';
$str = 'one=1&two=2&=3&tr=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);