#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z-_][^A-Z\s]{1,21}$"
Local $sString = "lkjlksjdfdsqf" & @CRLF & _
"lkjljl-----kjlkj-" & @CRLF & _
"klhlkhsdf---fdqsd__T" & @CRLF & _
"klhlkhsdfsdf---fdqs dfqds_"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")