using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z-_][^A-Z\s]{1,21}$";
string input = @"lkjlksjdfdsqf
lkjljl-----kjlkj-
klhlkhsdf---fdqsd__T
klhlkhsdfsdf---fdqs dfqds_";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}