#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?! PAGE)[A-Z0-9\s])+[A-Z](?: \d{4})?\b"
Local $sString = "FREE SOFT FOUNDATION V2 1989 PAGE 2" & @CRLF & _
"STALLMANWORKS 2000 1977;PAGE 2" & @CRLF & _
"THE GNU PAGE 3 1977"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")