$re = '/(?:\w{1,2}-\d{1,4})+\w/m';
$str = 'D-1150A
D-1150B
D-1150C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);