use strict;
my $str = 'thisisstringtoreplace';
my $regex = qr/(?<=\G(?!^)|to)./mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";