const regex = new RegExp('[$#]+(?=[A-Za-z])', 'gm')
const str = `This\$#is
This\$#`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);