#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Guatemala, ([A-Z]+) (\d+) (de) (.+) (de) (\d+)$"
Local $sString = "ERO 65" & @CRLF & _
"23" & @CRLF & _
"(279248-2)–7–julio" & @CRLF & _
"(279249-2)–7–julio" & @CRLF & _
"(VSN-0973)–7–julio" & @CRLF & _
"(279269-2)–7–julio" & @CRLF & _
"" & @CRLF & _
"24" & @CRLF & _
"Guatemala, VIERNES 7 de julio de 2023" & @CRLF & _
"NÚMERO 65" & @CRLF & _
"DIARIO de CENTRO AMÉRICA" & @CRLF & _
"(279246-2)–7–julio" & @CRLF & _
"(279214-2)–7–julio"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")