import Foundation
let pattern = #"^Guatemala, ([A-Z]+) (\d+) (de) (.+) (de) (\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ERO 65
23
(279248-2)–7–julio
(279249-2)–7–julio
(VSN-0973)–7–julio
(279269-2)–7–julio
24
Guatemala, VIERNES 7 de julio de 2023
NÚMERO 65
DIARIO de CENTRO AMÉRICA
(279246-2)–7–julio
(279214-2)–7–julio
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)