re = /https?:\/\/[^\/]+/
str = 'https://example0.com/example.php?id=example0
https://example1.com/example.php?id=example1
https://example2.com/example.php?id=example2
http://www.google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end