#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\b[AZQ]\d{10,14}(>\S+).*?(First Time : \d\d:\d\d[AP]M)"
Local $sString = "qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*" & @CRLF & _
"]*,qgvv]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<" & @CRLF & _
"['~£,'}'<',!']'',',<€~Z1234566789>Z12345667890" & @CRLF & _
"1'fncnr'qmtjcsmsj194&($.!:!" & @CRLF & _
",$/&15?'?'(''(('(''158,$3,!!1" & @CRLF & _
"1'('(',';?1!( First Time : 10:10PM" & @CRLF & _
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq" & @CRLF & _
"AAABBB : ,$2$$(&158((&&,&,&;&(&&((&" & @CRLF & _
"" & @CRLF & _
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*" & @CRLF & _
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<" & @CRLF & _
"['~£,'}'<',!']'',',<€~A1234566789>A1234566789123" & @CRLF & _
"1'fncnr'qmtjcsmsj194&($.!:!" & @CRLF & _
",$/&15?'?'(''(('(''158,$3,!!1" & @CRLF & _
"1'('(',';?1!( First Time : 10:10PM" & @CRLF & _
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq" & @CRLF & _
"AAABBB : :&;&;&(&;'1(&?&,&,&1&(&(," & @CRLF & _
"$2$$(&158((&&,&,&;&(&&((&;&;&;&;&" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"qitjfjdjqkfjjf 1934848[*{*}*}*#*#*#[#*" & @CRLF & _
"]*,€]*?£[£?£,£~'_!~£[££<£<'<'?£]!<!<" & @CRLF & _
"['~£,'}'<',!']'',',cjejfnfn<€~Q1234566789>Q123456678912" & @CRLF & _
"1'fncnr'qmtjcsmsj194&($.!:!" & @CRLF & _
",$/&15?'?'(''(('(''158,$3,!!1" & @CRLF & _
"1'('(',';?1!( First Time : 10:10PM" & @CRLF & _
"1&4$,!;($qmfjccn1'fkfkckcqtngcnnq" & @CRLF & _
"dbxbxne AAABBB : ,$2$$(&158((&&,&,&;&(&&((&"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")