package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<img([\w\W]+?)\/?>`)
var str = `<img src="imagem1">
texto
<img src="imagem2.jpg">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}