re = /(?|\b(\w+)(?= +\1\b) +|\G(?!^)(\w+))/m
str = 'pds dd dd dd dd sd dd ss ss dd ee ee ee ee ee ee ee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end