using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|[^\\\n])\\(?:\\{2})*(??\b)\d+(?:\.\d*)?";
string input = @"\5
\\5
\\\5
\\\4
\4.
\44
\4456
\\\6
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}