$re = '/submitted by .+? ([^\s,]+)(?:,? (?:[JS]r\.?|Esq\.|III?|IV))? :/m';
$str = 'The following records request has been submitted by Bryan Trummer :
The following records request has been submitted by Ray Parker Jr. :
The following records request has been submitted by William Stanley Preston, Esq. :
The following records request has been submitted by Marshall Bruce Mathers III :
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);