import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([A-Z][a-z],?)+\\).*$";
final String string = "Super Mario Bros. 8 (En,Fr,De,Es,It)\n"
+ "Donald Duck in Whacky Land (En,Fr,De,Es,Sv)\n"
+ "Toadstool Adventures 3D (En)\n"
+ "Chinaland (En,De)\n"
+ "A title which doesn't have any such thing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}