#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\d{8})((?:0*)(\d{,8}))(?=\d{8})"
Local $sString = "112233441234567855667788 --> 12345678" & @CRLF & _
"112233440012345655667788 --> 123456" & @CRLF & _
"112233001234567855667788 --> 12345678" & @CRLF & _
"112233000012345655667788 --> 123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")