re = /(?<=\d{8})((?:0*)(\d{,8}))(?=\d{8})/
str = '112233441234567855667788 --> 12345678
112233440012345655667788 --> 123456
112233001234567855667788 --> 12345678
112233000012345655667788 --> 123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end