re = /^\+?[0-9()\s-]{8,25}[0-9]$/m
str = '+123456789
+1 234 567 8910
1 (234) 567 8910
1 (234) 567-8910
+1-234-567-8910
1 234 567 8910
"123456789"
\'123456789\'
/123456789/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end