# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((@[\w\d][\w\d_]+)\s+)?(\.[\w\d][\w\d_]+\s+)"
test_str = ("@array .byte 3, 4, 23\n"
"va1 .byte 'A', -3, 0xAB // Three bytes\n"
"@str1 .byte \"Enter an integer: \" // Null-terminated string\n"
"@var2 .hword 0xABCD:10 // 0xABCD is replicated 10 times\n"
"@var3 .word -18, 5.7E-3 // 4-byte integer, single float\n"
"@var4 .dword 21, 21.0 // 8-byte integer, double float\n\n"
"//Assembly Language Syntax:\n"
"J @label // Jump @label\n"
"JAL @label // R31 = (PC+4); Jump @label\n"
"The JAL instruction saves the return address ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.