$re = '/^[a-zA-Z0-9].{2,3}$/m';
$str = 'a
abc
abcd
abcde
a1
a12
a123
a1234
aa1
aa12
aa123
aa1234
a1
a1a
a1a1
a1a1a
a-
a-1
a-1a
a-1-
a-1a-
0012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);