# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\/[^\/]+$//gm;t' <<< "https://abc.xyz/f/b/go_cc_Jpterxvid_avi_mp4"