package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+\.\d+`)
var str = `TOKEN (SwapToken) - 1005.00000127 TOKEN
10.2
12421421412.4214124214
24213.2123321
3432.423`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}