re = /\d+\.\d+/
str = 'TOKEN (SwapToken) - 1005.00000127 TOKEN
10.2
12421421412.4214124214
24213.2123321
3432.423'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end