re = /(?<operator> [A-Z]+ (?=([^\"]*\"[^\"]*\")*[^\"]*$))/m
str = 'method(ARG,"No AND Yes OR other") OR method(ARG,ARG) AND method(ARG,ARG)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end