package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)vat[\s.]*[rn]`)
var str = `vat registration no.
vat number:
our vat number
vat
VAT amount
VAT rate
seller vat.reg.no. FI25891989
vat rate`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}