import re
regex = re.compile(r"vat[\s.]*[rn]", flags=re.MULTILINE)
test_str = ("vat registration no.\n"
"vat number:\n"
"our vat number\n"
"vat\n"
"VAT amount\n"
"VAT rate\n"
"seller vat.reg.no. FI25891989\n"
"vat rate")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")