re = /vat[\s.]*[rn]/m
str = 'vat registration no.
vat number:
our vat number
vat
VAT amount
VAT rate
seller vat.reg.no. FI25891989
vat rate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end