$re = '/Hello.*world/m';
$str = 'my Hello world. This is mongo
hh Hello. This is mongo world
world. This is mongo Hello
Hello world
world Hello
world hello
hello world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);