import Foundation
let pattern = #"\blog\.(?:info|warn|error)\((?!\s*`DEBUG\b)[\w\W]*?\);"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
log.info(
`DEBUG other strings...
);
log.info(
`remove this instruction!!!
);
log.info(
`DEBUG other strings...
);
log.info(`remove this instruction!!!);
log.info(`DEBUG other strings...);
log.info(
`other strings DEBUG...
);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)