use strict;
my $str = '11,22,33,44,55,111
22,33,11,44,55,111
22,33,44,55,111,11';
my $regex = qr/^11,|,11\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";