# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-0+([1-9]\d*)$/-$1/gm;t' <<< "020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001"