#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)-0+([1-9]\d*)$"
Local $sString = "020200218-0PSS-0010" & @CRLF & _
"020200218-0PSS-001" & @CRLF & _
"020200218-0PSS-00" & @CRLF & _
"020200218-0PSS-001001"
Local $sSubst = "-$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)