package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-0+([1-9]\d*)$`)
var str = `020200218-0PSS-0010
020200218-0PSS-001
020200218-0PSS-00
020200218-0PSS-001001`
var substitution = "-$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}