use strict;
my $str = '1576
01:14:04,440 --> 01:14:05,780
what\'s optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it\'s got to be much stronger than the RDA the recommended';
my $regex = qr/(?m)^[\d]+.+\R/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";