// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?m)^[\d]+.+\R").unwrap();
let string = "1576
01:14:04,440 --> 01:14:05,780
what's optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it's got to be much stronger than the RDA the recommended";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}