import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(?m)^[\d]+.+\R"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1576
01:14:04,440 --> 01:14:05,780
what's optimal daily allowance means. Which is good for 100 reasons.
1577
01:14:06,380 --> 01:14:09,970
That it's got to be much stronger than the RDA the recommended
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)