# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/("\w.[^\\]+)\\n ?/\1/gm;t' <<< "\n \"this is some text \n this should not be on the new line\" \n \"asdflksd sdflk \n sdafsdf\""