package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("\w.[^\\]+)\\n ?`)
var str = `\n "this is some text \n this should not be on the new line" \n "asdflksd sdflk \n sdafsdf"`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}