const regex = /[0-9]+(?= |$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9]+(?= |$)', 'g')
const str = `32132132132 32132132132 321321321323 32132132132132`;
const subst = `'$0',`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);