import Foundation
let pattern = #"[0-9]+(?= |$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"32132132132 32132132132 321321321323 32132132132132"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'$0',"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)