$re = '/^[3-8]{1}\'([0-9]{1}|0[0-9]{1}|1[0-1]{1})(\"|\s*((1\/4|1\/2|3\/4))\")$/m';
$str = '2\'11"
3\'00"
4\'11"
5\'6"
5\'11"
6\'0"
7\' 1"
5\'2 1/2"
5\'0"
5\'8 3/4"
7\'0"
7\'20"
6\'1"
6\'12"
6\'1 1/3"
6\'1 4/1"
6\'1 1/4"
6\'1 2/4"
6\'1 3/4"
6\'11 3/4"
7\'1"
7\'2"
7\'9"
7\'10"
7\'12"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);