package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]+\.key\.[^.]+$`)
var str = `bar.key.door
fruit.bar.key.door`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}