// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Keyword1: (.*?)(Keyword2:|\\r\\n)").unwrap();
let string = "\"Keyword1: That text I want \\r\\n Keyword2: Value2 \\r\\n Keyword3: Keyword2 \\r\\n Keyword4: Value4\"
\"Keyword1: That text I want Keyword2: Value2 \\r\\n Keyword3: Value3 \\r\\n Keyword4: Value4\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}