const regex = /\s+(?:n$)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+(?:n$)?', 'gi')
const str = `j o h n`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);