import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/\\*).*(?=\\*\\/)";
final String string = "/*\n"
+ "//This is the test string\n"
+ "with a big\n\n"
+ "comment\n"
+ "*/\n\n"
+ "sadasdasdsa\n\n"
+ "asdasdasdasdas";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}