$re = '/([^\pL\pN\pP\pS\pZ])|([\xC2\xA0])/u';
$str = 'line_1
line_2';
$subst = " ";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;