$re = '/(?<=lyrics-eng=)(?:[\w ]+\s)+/m';
$str = ';FFMETADATA1
album=name of the album
artist=name of the artist
title=name of the title
lyrics-eng=line1 of lyrics
line2 of lyrics
line3 of lyrics
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);